Faille de sécurité sur PrestaShop >= 1.7.5

Faille de sécurité

La team PrestaShop a identifié une faille majeure de sécurité qui touche toutes les versions de PrestaShop à partir de la version 1.7.5.

Cette faille est dès ce jour corrigé sur la version 1.7.8.2 disponible en téléchargement sur le site de PrestaShop.

Corriger la faille

1 - Par la mise à jour de PrestaShop

Cette solution est la plus adaptée car elle permet de profiter de toutes les améliorations apportées par la dernière version de PrestaShop mais elle engage une procédure longue, couteuse et aussi dangereuse car nous le savons tous, PrestaShop ne se met pas à jour simplement et vous devez surtout faire très attention à toutes les modifications pouvant bloquer les templates personnalisés qui doivent, eux aussi, être mis à jour.

2 - application d'un patch

Il est possible d'appliquer un patch pour corriger les versions de PrestaShop sans devoir faire la mise à jour complète.

Cette solution est la plus rapide pour ne pas mettre en péril son commerce et sécuriser son installation sans devoir faire de grosse mise à jour.

Conclusion

Quel que soit votre choix ou votre besoin, n'hésitez pas à prendre contact avec moi si vous souhaitez que je m'occupe de la sécurisation de votre installation PrestaShop.